HDU-1058DP打表

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29416    Accepted Submission(s): 12880


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
 
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
 
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.

题意:就是找出2,3,5,7的倍数中第几位来,有点打表的意思。

坑点:主要是输出部分,11,12,13后缀都是th,这个是坑。

AC代码:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[6000];
int main()
{
    int n,a,b,c,d,m;
    int Min,Max;
    dp[1]=1;
    a=b=c=d=1;
    n=1;
    while (n<=5842)
        {
            Min=min(2*dp[a],min(3*dp[b],min(5*dp[c],7*dp[d])));        //*dp[i]可以避免重复
            dp[++n]=Min;
            if (Min==2*dp[a])
                a++;
            if (Min==3*dp[b])
                b++;
            if (Min==5*dp[c])
                c++;
            if (Min==7*dp[d])
                d++;
        }
    while (cin>>m&&m)
        {
            if (m%10==1&&m%100!=11)
                printf("The %dst humble number is %d.\n",m,dp[m]);
            else if (m%10==2&&m%100!=12)
                    printf("The %dnd humble number is %d.\n",m,dp[m]);
                else if (m%10==3&&m%100!=13)
                        printf("The %drd humble number is %d.\n",m,dp[m]);
                    else printf("The %dth humble number is %d.\n",m,dp[m]);
        }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/z1164754004z/article/details/81002451
今日推荐