HDU - 1398 完全背包问题求方案数

题目描述:
Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, …, and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input
2
10
30
0

Sample Output
1
4
27

题目链接:Square Coins
解法思路:
题目大意就是凑平方数,即有17种物品(完全平方数),凑出指定价值量(给定整数n),有多少种凑法。典型的完全背包问题,求方案数的递推式是:dp[j]+=dp[j-w[i]];
代码展示:

#include<bits/stdc++.h>
using namespace std;
int dp[310]={1},n;
int w[]={0,1,4,9,16,25,36,49,64,81,100,121,144,169,196,225,256,289};
int main()
{
    while(cin>>n,n)
    {
        memset(dp,0,sizeof dp); dp[0]=1;
        for(int i=1;i<=17;i++)
        {
            for(int j=w[i];j<=n;j++)   dp[j]+=dp[j-w[i]];
        }
        cout<<dp[n]<<endl;
    }
    return 0;
}

发布了43 篇原创文章 · 获赞 56 · 访问量 5141

猜你喜欢

转载自blog.csdn.net/tran_sient/article/details/94992106