LightOJ 1369

Description

The problem you need to solve here is pretty simple. You are give a function f(A, n), where A is an array of integers and n is the number of elements in the array. f(A, n) is defined as follows:

long long f( int A[]int n ) { // n = size of A

    long long sum = 0;

    for( int= 0; i < n; i++ )

        for( int= i + 1; j < n; j++ )

            sum += A[i] - A[j];

    return sum;

}

Given the array A and an integer n, and some queries of the form:

1)      0 x v (0 ≤ x < n, 0 ≤ v ≤ 106), meaning that you have to change the value of A[x] to v.

2)      1, meaning that you have to find f as described above.

Input

Input starts with an integer T (≤ 5), denoting the number of test cases.

Each case starts with a line containing two integers: n and q (1 ≤ n, q ≤ 105). The next line contains n space separated integers between 0 and 106 denoting the array A as described above.

Each of the next q lines contains one query as described above.

Output

For each case, print the case number in a single line first. Then for each query-type "1" print one single line containing the value of f(A, n).

Sample Input

1

3 5

1 2 3

1

0 0 3

1

0 2 1

1

Sample Output

Case 1:

-4

0

4


O(n)预处理出sum,O(1)修改sum,虽然题目中a[i]小于1e6,不过可以修改1e5次,因此a[n]用LL

#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
typedef long long LL;
const int maxn = 1e5+5;
LL a[maxn];
int n, q;

int main(){
    int T;
    scanf("%d", &T);
    for(int nCase = 1; nCase <= T; nCase++){
        LL sum = 0;
        scanf("%d%d", &n, &q);
        memset(a, 0, sizeof(a));
        printf("Case %d:\n", nCase);
        for(int i = 0; i < n; i++){scanf("%lld", &a[i]);sum += (n-1-2*i)*a[i];}
        while(q--){
            int type;
            scanf("%d", &type);
            if(type == 0){
                int v, x;
                scanf("%d%d", &v, &x);
                sum += (n-1-2*v)*(x-a[v]);
                a[v] = x;
            }
            else printf("%lld\n", sum);
        }
    }

    return 0;
}


发布了14 篇原创文章 · 获赞 3 · 访问量 1137

猜你喜欢

转载自blog.csdn.net/qq_33808530/article/details/51939601
今日推荐