【LightOJ-1369】 Answering Queries 规律

版权声明:抱最大的希望,为最大的努力,做最坏的打算。 https://blog.csdn.net/qq_37748451/article/details/86548931

The problem you need to solve here is pretty simple. You are give a function f(A, n), where A is an array of integers and nis the number of elements in the array. f(A, n) is defined as follows:

long long f( int A[]int n ) { // n = size of A

    long long sum = 0;

    for( int i = 0; i < n; i++ )

        for( int j = i + 1; j < n; j++ )

            sum += A[i] - A[j];

    return sum;

}

Given the array A and an integer n, and some queries of the form:

1)      0 x v (0 ≤ x < n, 0 ≤ v ≤ 106), meaning that you have to change the value of A[x] to v.

2)      1, meaning that you have to find f as described above.

Input

Input starts with an integer T (≤ 5), denoting the number of test cases.

Each case starts with a line containing two integers: n and q (1 ≤ n, q ≤ 105). The next line contains n space separated integers between 0 and 106 denoting the array A as described above.

Each of the next q lines contains one query as described above.

Output

For each case, print the case number in a single line first. Then for each query-type "1" print one single line containing the value of f(A, n).

Sample Input

1

3 5

1 2 3

1

0 0 3

1

0 2 1

1

Sample Output

Case 1:

-4

0

4

Note

Dataset is huge, use faster I/O methods.

 

有两个操作:

0  x  v将A[x]转变成v。

1计算函数f的值

分析:

推出规律

n个数,用a,b,c......表示 ,推出来为:

(n-1)*a[1]+(n-3)*a[2]+(n-5)*a[3].......

归纳话的规律为:

(n-(2*i-1))*a[i]

#include<iostream>
#include<cstdio>
using namespace std;
typedef long long LL;
const int N=1e5+5;
int a[N];
 
int main(){
    int T;
    scanf("%d",&T);
    int cas=0;
    while(T--){
        int n,q;
        scanf("%d%d",&n,&q);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        printf("Case %d:\n",++cas);
        LL sum=0;
        for(int i=0;i<n;i++){
            sum+=(LL)(n-1-2*i)*a[i];
        }
        while(q--){
            int op;
            scanf("%d",&op);
            if(op==1){
                printf("%lld\n",sum);
            }
            else{
                int pos,v;
                scanf("%d%d",&pos,&v);
                sum-=(LL)(n-2*pos-1)*a[pos];
                sum+=(LL)(n-2*pos-1)*v;
                a[pos]=v;
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/qq_37748451/article/details/86548931