1074 Reversing Linked List (25分) 第五个测试点:答案错误 我的代码+别人的代码

1074 Reversing Linked List (25分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

第五测试点:答案错误原因是 存在一些不在头结点引出的链表上的结点。

我的代码:

收获:cout输出string可能超时

可以用printf 输出 格式:str.c_str()

#include<iostream>
#include<map>
#include<algorithm>
#include<vector>
#include<cstring>
using namespace std;
struct node{
	string ad;
	int d;
	string next;
};
map<string,node>::iterator ip;
int main()
{
	map<string,node> s;
	vector<node> a,b;
	b.clear();
	a.clear();
	s.clear();
	
	int i,j,t,n,len;
	string add,k;
	node temp;
	
	cin>>add>>n>>t;
	for(i=0;i<n;i++)
	{
		cin>>temp.ad>>temp.d>>temp.next;
		s.insert(make_pair(temp.ad,temp));
	}
	for(i=0;i<n;i++)
	{
		if(s.count(add))
		{
			ip=s.find(add);
			a.push_back(ip->second);
			add=ip->second.next;
//			cout<<1<<endl;
		}
		
	}
	n=a.size();
	for(i=t;i<=n;)
	{
		for(j=1;j<=t;j++)
		{
//			cout<<a[i-j].ad<<" "<<a[i-j].d<<" "<<a[i-j].next<<endl;
			b.push_back(a[i-j]);
		}
		i+=t;
	}
	if(i!=n)
	{
		i-=t;
		for(j=i;j<n;j++)
		{
			b.push_back(a[j]);
		}
	}
	len=b.size()-1;
	for(i=0;i<len;i++)
	{
		printf("%05s %d %05s\n",b[i].ad.c_str(),b[i].d,b[i+1].ad.c_str());
//		cout<<b[i].ad<<" "<<b[i].d<<" "<<b[i+1].ad<<endl;
	}
//	cout<<b[len].ad<<" "<<b[b.size()-1].d<<" -1"<<endl;
    printf("%05s %d -1\n",b[len].ad.c_str(),b[len].d);
	return 0;
}

别人的代码:

#include <iostream>
#include<fstream>
using namespace std;
int main() {
    int h, k, n, sum = 0;
#ifdef _DEBUG
	ifstream cin("data.txt");
#endif
    cin >> h >> n >> k;
    int temp, data[100005], next[100005], list[100005], result[100005];
    for (int i = 0; i < n; i++) {
        cin >> temp;
        cin >> data[temp] >> next[temp];
    }
    while (h != -1) {
        list[sum++] = h;
        h = next[h];
    }
    for (int i = 0; i < sum; i++) result[i] = list[i];
    for (int i = 0; i < (sum - sum % k); i++)
        result[i] = list[i / k * k + k - 1 - i % k];
    for (int i = 0; i < sum - 1; i++)
        printf("%05d %d %05d\n", result[i], data[result[i]], result[i + 1]);
    printf("%05d %d -1", result[sum - 1], data[result[sum - 1]]);
#ifdef _DEBUG
	cin.close();
#endif
    return 0;
}
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn = 1e5+100;
int a[maxn],c[maxn];
int b[maxn][2];
int main()
{
	int digit,n,m;
	scanf("%d%d%d",&digit,&n,&m);
	for(int i = 1; i <= n; i++)
	{
		int x,y,z;
		scanf("%d%d%d",&x, &y, &z);
		b[x][0] = y;
		b[x][1] = z;
	}
	int gg = 0;
	a[++gg] = digit;
	for(++gg;a[gg-1] != -1;++gg)
		a[gg] = b[a[gg-1]][1];
	gg--;gg--;
//	cout<<gg<<endl;	
//	for(int i =1 ; i<=gg;i++)
//		cout<<a[i]<<endl;	
	int now = 0,i;
	for(i = m;i <= gg; i += m )
	{
		for(int j = i; j > i-m; j--){
			c[++now] = a[j];	
		}
	}
	if(i>gg){
		for(i = i- m + 1; i <= gg;i++)
			c[++now] = a[i];
	}
	for(int i = 1 ; i < gg;i++)
		printf("%05d %d %05d\n",c[i],b[c[i]][0],c[i+1]); 	
	printf("%05d %d %d\n",c[gg],b[c[gg]][0],-1); 	
	return 0;
} 
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
const int maxn = 1e5 + 10;
struct Node 
{
	int add, data, next;
}node[maxn];
void init()
{
	for (int i = 0; i < maxn; i++)node[i].add = i;
}
int head, n, k;
vector<Node>list;
int main()
{
	scanf("%d%d%d", &head, &n, &k);
	init();
	for (int i = 0; i < n; i++)
	{
		int address;
		scanf("%d", &address);
		scanf("%d%d", &node[address].data, &node[address].next);
	}
	int p = head;
	while (p != -1)
	{
		list.push_back(node[p]);
		p = node[p].next;
	}
	int group = list.size() / k;
	for (int i = 0; i < group; i++)
	{
		reverse(list.begin() + i*k, list.begin() + i*k + k);
	}
	for (int i = 0; i < list.size(); i++)
	{
		printf("%05d %d ", list[i].add, list[i].data);
		if (i != list.size() - 1)printf("%05d", list[i + 1].add);
		else printf("-1");
		printf("\n");
	}
	return 0;
}
发布了374 篇原创文章 · 获赞 101 · 访问量 21万+

猜你喜欢

转载自blog.csdn.net/qq_41325698/article/details/103466109