1074 Reversing Linked List (25)(25 分)

1074 Reversing Linked List (25)(25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 10^5^) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

扫描二维码关注公众号,回复: 2778202 查看本文章
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

这题刚开始用list和map写 超时了

后来改成数组的写法 

嗯.......最后一个测试点错了  我也不知道什么原因 是看网上的   他人的博客说是 可能存在!!!!!那种 不需要在这个链表出现的结点。。。嗯 改了下就对了

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn = 1e5+100;
int a[maxn],c[maxn];
int b[maxn][2];
int main()
{
	int digit,n,m;
	scanf("%d%d%d",&digit,&n,&m);
	for(int i = 1; i <= n; i++)
	{
		int x,y,z;
		scanf("%d%d%d",&x, &y, &z);
		b[x][0] = y;
		b[x][1] = z;
	}
	int gg = 0;
	a[++gg] = digit;
	for(++gg;a[gg-1] != -1;++gg)
		a[gg] = b[a[gg-1]][1];
	gg--;gg--;
//	cout<<gg<<endl;	
//	for(int i =1 ; i<=gg;i++)
//		cout<<a[i]<<endl;	
	int now = 0,i;
	for(i = m;i <= gg; i += m )
	{
		for(int j = i; j > i-m; j--){
			c[++now] = a[j];	
		}
	}
	if(i>gg){
		for(i = i- m + 1; i <= gg;i++)
			c[++now] = a[i];
	}
	for(int i = 1 ; i < gg;i++)
		printf("%05d %d %05d\n",c[i],b[c[i]][0],c[i+1]); 	
	printf("%05d %d %d\n",c[gg],b[c[gg]][0],-1); 	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/81587024