1074 Reversing Linked List (25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

结尾无空行

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

结尾无空行

#include<iostream>
#include<vector>
using namespace std;
struct Node{
int data;
int next;
};
Node node[100005];
int head,N,K;
vector<int>v;
int main()
{
	int a, b, c, d,temp;
	cin >> head >> N >> K;
	while (N--)
	{
		cin >> a >> b >> c;
		node[a].data = b;
		node[a].next = c;
	}
	for (int i = head; i != -1; i = node[i].next)
	{
		v.push_back(i);		//将下标放进去
	}
	for (int i = 0; i + K <= v.size(); i += K)		//注意边界条件 每k项进行一次翻转,如果最后一堆数量小于K就不反转了
	{
		//用头尾互换的方式进行翻转
		a = i, b = i + K - 1;
		while (a < b) {		//用while循环比较简单
			temp = v[a];
			v[a] = v[b];
			v[b] = temp;
			a++, b--;
		}
	}
	printf("%05d %d ", v[0], node[v[0]].data);		//输出第一个的下标以及值
	for (int i = 1; i < v.size(); i++)		//输出技巧
	{
		printf("%05d\n%05d ", v[i], v[i]);
		printf("%d ", node[v[i]].data);
	}
	cout << "-1";



}

猜你喜欢

转载自blog.csdn.net/qq_52245648/article/details/120517905