【PAT】B1025/A1074. Reversing Linked List (25)

Description:
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.


Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218


Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

//NKW 乙级真题1015
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
#include <map>
using namespace std;
const int maxn = 100010;
struct n{
	int data;
	int next;
}num;
map<int, n> mp;
int laddress[maxn], ldata[maxn], lnext[maxn];
void re(int &a, int &b){
	int temp;
	temp = a;
	a = b;
	b = temp;
}
int main(){
	int begin, n, k, address, idata, inext, i, cnt = 0, cnt1 = 0;
	scanf("%d %d %d", &begin, &n, &k);
	for (i = 0; i < n; i++){
		scanf("%d %d %d", &address, &idata, &inext);
		mp[address].data = idata;
		mp[address].next = inext;
	}
	for (i = 0; i < n; i++){
		laddress[i] = begin;
		ldata[i] = mp[begin].data;
		lnext[i] = mp[begin].next;
		begin = mp[begin].next;
		cnt++;
		if (begin == -1)	break;
	}
	for (i = k; i <= cnt; i += k){
		cnt1 = 1;
		for (int j = i - k; j < i - k / 2; j++){
			re(laddress[j], laddress[i - cnt1]);
			re(ldata[j], ldata[i - cnt1++]);
		}
	}
	for (i = 0; i < cnt; i++){
		printf("%05d %d ", laddress[i], ldata[i]);
		if (i == cnt - 1)	printf("-1\n");
		else	printf("%05d\n", laddress[i + 1]);
	}
	system("pause");
	return 0;
}

程序分析:

此方法其实是凑,与链表没什么关系。

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/81292441