【笨方法学PAT】1074 Reversing Linked List (25 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/84625401

一、题目

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

二、题目大意

k个一轮,对链表进行排序。

三、考点

链表

四、注意

1、首先清洗;

2、注意反转的方式以及最后剩余节点的处理。

五、代码

#include<iostream>
#include<vector>
#include<algorithm>
#define N 100005
using namespace std;
struct node {
	int add;
	int val;
	int next;
};
vector<node> vec(N), v, v1, v2;
vector<bool> visit(N, false);
int main() {
	//read
	int add, n, k;
	cin >> add >> n>>k;
	for (int i = 0; i < n; ++i) {
		int a;
		node nd;
		cin >> a >> nd.val >> nd.next;
		nd.add = a;
		vec[a] = nd;
	}

	//clear
	while (add != -1) {
		v.push_back(vec[add]);
		add = vec[add].next;
	}
	
	//reverse
	for(int i=0;i<v.size()/k;++i){
		for (int j = k-1; j >= 0; --j) {
			int id = i * k + j;
			v1.push_back(v[id]);
		}
	}
	for(int i=v.size()/k*k;i<v.size();++i)
		v1.push_back(v[i]);

	//output
	if (v1.size() != 0) {
		for (int i = 0; i < v1.size() - 1; ++i) {
			printf("%05d %d %05d\n", v1[i].add, v1[i].val, v1[i + 1].add);
		}
		printf("%05d %d -1\n", v1[v1.size() - 1].add, v1[v1.size() - 1].val);
	}

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/84625401