PAT 1074. Reversing Linked List (25)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237

68237 6 -1

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
struct Node{
  int address;
  int data;
  int next;
};
Node arr[1000001];
Node v[1000001];
int main()
{
  int start_address,n,k;
  cin>>start_address>>n>>k;
  bool flag = false;
  for(int i = 0; i < n; i++)
  {
    int address,data,next;
    cin>>address>>data>>next;
    arr[address].address = address;
    arr[address].data = data;
    arr[address].next = next;
    if(address == start_address)
     flag = true;
  }
  if(flag)
  {
    int tmp = start_address;
    int t = 0;
    while(tmp != -1)
    {
      v[t++] = arr[tmp];
      tmp = arr[tmp].next;
    }
    for(int i = 0; i < t; i++)
    {
      for(int j = 1; j < k; j++,i++);
      if(i < t)
      {
        reverse(v+i-k+1,v+i+1);
      }
    }
    for(int i = 0; i < t; i++)
    {
      if(i < t - 1)
        printf("%05d %d %05d\n",v[i].address,v[i].data,v[i+1].address);
      else
        printf("%05d %d -1\n",v[i].address,v[i].data);
    }
  }
  else
  cout<<-1<<endl;
  return 0;
}


猜你喜欢

转载自blog.csdn.net/hickey_chen/article/details/80145330