PATA 1074.Reversing Linked List (25)解题报告

Reversing Linked List(25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (105) which is the total number of nodes, and a positive K (N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
作者: 陈越
单位: 浙江大学
时间限制: 400ms
内存限制: 64MB
代码长度限制: 16KB

AC代码:

//Reversing Linked List (25)
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;


#define MAXSIZE 1000010
struct List //存储数据和链表下一项的地址 
{
    int Data;
    int Next;
}List[MAXSIZE];
int result[MAXSIZE];
int main()
{
	int first,n,k;
	int address,data,next;
	cin>>first>>n>>k;
	for(int i=0;i<n;i++)//按照地址存储信息 
	{
		cin>>address>>data>>next;
		List[address].Data=data;
		List[address].Next=next;
	}
	int j=0,p;
	p=first;//指向首节点
	while(p!=-1)//将链接好的节点存储在一个顺序数组中 
	{
		result[j++]=p;
		p=List[p].Next;
	}
	int i=0;
	while(i+k<=j)//翻转i~i+k之间的所有元素,即实现按k翻转
	{
		reverse(&result[i],&result[i+k]);
		i=i+k;
	}
	for(i=0;i<j-1;i++)//result数组中不存储数据,只存储地址,按照result所给地址输出List的内容 
		printf("%05d %d %05d\n",result[i],List[result[i]].Data,result[i+1]);
	printf("%05d %d -1\n",result[i],List[result[i]].Data);
	return 0;
}
//string str="C++REVERSE";
//reverse(str.begin(),str.end());//str结果为ESREVER++C
//cout<<str;
总结:新学习到了C++中的reverse函数,可以按照给定的范围翻转一整个序列,相当于反复调用了多次swap;

猜你喜欢

转载自blog.csdn.net/qq_33657357/article/details/80407542