PAT 1074 Reversing Linked List (25 分)

1074 Reversing Linked List (25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.


Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤ 1 0 5 10^5 ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.


Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1




解析

#include<algorithm>
#include<cstdio>
#include<iostream>
#include<vector>
using namespace std;
struct N{
	int address, value, next;
}Node[100000];
int main()
{
	int start, N, K;
	int address;
	scanf("%d %d %d", &start, &N, &K);
	for (int i = 0; i < N; i++) {
		scanf("%d", &address);
		Node[address].address = address;
		scanf("%d %d", &Node[address].value, &Node[address].next);
	}
	int len = 0;
	int p = start, q = Node[start].next,t;
	while (p != -1) {
		p = Node[p].next;
		len++;
	}
	p = start;
	int reverse_time = len / K;
	vector<int> list;
	while (reverse_time--) {
		for (int i = 0; i < K - 1; i++) {
			t = Node[q].next;
			Node[q].next = p;
			p = q;
			q = t;
		}
		list.push_back(p);
		Node[start].next = -1;
		start = q;
		p = q;
		q = Node[q].next;
	}
	if (p != -1)
		list.push_back(p);
	p = list.front();
	for (int i = 0; i < list.size()-1; i++) {
		while (Node[p].next != -1)
			p = Node[p].next;
		Node[p].next = list[i + 1];
	}
	p = list.front();
	while (Node[p].next != -1) {
		printf("%05d %d %05d\n", Node[p].address, Node[p].value, Node[p].next);
		p = Node[p].next;
	}
	printf("%05d %d -1\n", Node[p].address, Node[p].value);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41256413/article/details/84147321