1007 Maximum Subsequence Sum(PAT 甲等 C++实现)

1007 Maximum Subsequence Sum (25)(25 point(s))Questions

Given a sequence of K integers { N~1~, N~2~, ..., N~K~ }. A continuous subsequence is defined to be { N~i~, N~i+1~, ..., N~j~ } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

分析:

注意输出是第一个数和最后一个数,而并不是输出下标。

做法是一路加,并与最大值相比,而加到小于0后放弃。

详细代码:

#include <iostream>   
using namespace std;   
  
typedef struct{
	int l,r;
	int sum; 
}x;

// 1007 Maximum Subsequence Sum (25)(25 point(s))
int main(void){ 
	int n; cin>>n; 
	 
	x max,t;
	t.l = 0;
	t.r = 0;
	t.sum = 0;
	max = t; 
	max.sum = -1; // 注意是 -1
	int flag=0; 
	int a[10005]={0x00}; 
	for(int i=0;i<n;++i){
		cin>>a[i];  
		if(a[i]>=0){  
			flag = 1;   
		} 

		t.sum += a[i]; 
		if(t.sum>max.sum){
			t.r = i;
			max = t;
		}else if(t.sum<0){
			t.sum = 0;
			t.l = i+1;
		}  
	}  

	if(flag == 0){ 
		cout<<"0 "<<a[0]<<" "<<a[n-1]; // all negative
	}else{ 
		cout<<max.sum<<" "<<a[max.l]<<" "<<a[max.r]; 
	}
	 
	return 0;
}// jinzheng 2018.7.24 11:18

猜你喜欢

转载自blog.csdn.net/guangjinzheng/article/details/81183162