HDU 1492 The number of divisors(约数) about Humble Numbers

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.
 

Input

The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.

Output

For each test case, output its divisor number, one line per case.

Sample Input

 

4 12 0

Sample Output

 

3 6

 丑数的素因子只有2,3,5,7,给出一个丑数,求丑数的因子有多少。。。

丑数肯定满足2^a*3^b*5^c*7^d=n,那麽只要求出a,b,c,d的值就可以得出答案了。。。

a,b,c,d的值只需要一直除就可以得出。。

最后的答案为(a+1)*(b+1)*(c+1)*(d+1)。。。

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
long long int n;
int a[4]={2,3,5,7};
int re[4]={1,1,1,1};
int main()
{
    while (scanf("%lld",&n)!=EOF&&n)
    {
        long long int ans=1;
        for (int i=0;i<4;i++)
        {
            long long int t=n;
            int ci=1;
            while (t&&t%a[i]==0)
            {
                t/=a[i];
                ci++;
            }
            ans*=ci;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/82912866