Jug Hard

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/fores_t/article/details/75050603

Description
You have two empty jugs and tap that may be used to fill a jug. When filling a jug from the tap, you can only fill it completely (i.e., you cannot partially fill it to a desired level, since there are no volume measurements on the jug).

You may empty either jug at any point.

You may transfer water between the jugs: if transferring water from a larger jug to a smaller jug, the smaller jug will be full and there will be water left behind in the larger jug.

Given the volumes of the two jugs, is it possible to have one jug with some specific volume of water?

Input

The first line contains T, the number of test cases (1 ≤ T 100 000). Each test case is composed of three integers: a b d where a and b (1 ≤ a, b ≤ 10 000 000) are the volumes of the two jugs, and d is the desired volume of water to be generated. You can assume that d ≤ max(a,b).
Output

For each of the T test cases, output either Yes or No, depending on whether the specific volume of water can be placed in one of the two jugs.
Sample Input

3
8 1 5
4 4 3
5 3 4
Sample Output

Yes
No
Yes

题意:给你两个空的罐子,问你是否可以用这两个罐子获得一定体积的水,这两个罐子上都没有确定的刻度,若要用罐子接水则必须要接满。

思路:若这两个罐子的体积最大公约数是要获得的水的体积的因子则可以;否则不行。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
       int a,b,c;
       scanf("%d %d %d",&a,&b,&c);
       if(c%gcd(a,b)==0)
        printf("Yes\n");
       else
        printf("No\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/fores_t/article/details/75050603