HDU 1097 A hard puzzle

Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
 
  
7 66
8 800
 

Sample Output
 
  
9
6

分析:分析出最后一位数出现的规律即可。

#include <iostream>
#include <algorithm>
using namespace std;
int num[10][10] = {{0}, {1}, {2,4,8,6},{3,9,7,1},
{4,6}, {5}, {6}, {7,9,3,1}, {8,4,2,6}, {9,1}};
int main() {
	int a, b;
	while(cin>>a>>b) {
		a %= 10;
		if(a==0) cout<<"0"<<endl;
		if(a==1) cout<<"1"<<endl;
		if(a==5) cout<<"5"<<endl;
		if(a==6) cout<<"6"<<endl;
		if(a==2) {
			if(b%4==0) {
				cout<<num[2][3]<<endl;
			} else {
				cout<<num[2][(b%4)-1]<<endl;		
			}
		}
		if(a==3) {
			if(b%4==0) {
				cout<<num[3][3]<<endl;
			} else {
				cout<<num[3][(b%4)-1]<<endl;		
			}
		}
		if(a==7) {
			if(b%4==0) {
				cout<<num[7][3]<<endl;
			} else {
				cout<<num[7][(b%4)-1]<<endl;		
			}
		}
		if(a==8) {
			if(b%4==0) {
				cout<<num[8][3]<<endl;
			} else {
				cout<<num[8][(b%4)-1]<<endl;		
			}
		}
		if(a==9) {
			if(b%2==0) {
				cout<<num[9][1]<<endl;
			} else {
				cout<<num[9][(b%2)-1]<<endl;		
			}
		}		
		if(a==4) {
			if(b%2==0) {
				cout<<num[4][1]<<endl;
			} else {
				cout<<num[4][(b%2)-1]<<endl;		
			}
		}	
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/adusts/article/details/80671809
今日推荐