PAT (Advanced Level) Practice — 1006 Sign In and Sign Out (25 分)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37345402/article/details/86345021

题目链接:https://pintia.cn/problem-sets/994805342720868352/problems/994805516654460928

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

:题意  输入n个学生的id,签到时间和签离时间,找到最早签到的人和最晚签离的人。

:思路  将标准时间格式转化为秒,再进行比较。

#include<iostream>
using namespace std;
const int inf=99999999;
int ch(char a[]){
	int x=0;
	x+=(((a[0]-'0')*10+(a[1]-'0'))*3600);
	x+=(((a[3]-'0')*10+(a[4]-'0'))*60);
	x+=((a[6]-'0')*10+(a[7]-'0'));
	return x;
}
int main(){
	int st=0;
	int en=0;
	string na,na_st,na_en;
	char start[111],endd[111];
	int n;
	while(cin>>n){
		int min=inf;
		int max=0;
		for(int i=0;i<n;i++){
			cin>>na;
			cin>>start>>endd;
			st=ch(start);
			en=ch(endd);
			if(st<min){
				min=st;
				na_st=na;
			}
			if(en>max){
				max=en;
				na_en=na;
			}
		}
		cout<<na_st<<" "<<na_en<<endl;
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/m0_37345402/article/details/86345021