PAT (Advanced Level) Practice 1006 Sign In and Sign Out (25 分)(C++)(甲级)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/85686404

1006 Sign In and Sign Out (25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:

SC3021234 CS301133


#include <cstdio>
#include <cstring>
#include <cmath>

typedef struct Record
{
	char ID[20];
	int in_hh, in_mm, in_ss;
	int out_hh, out_mm, out_ss;

}Record;//记录

bool LessEqu(Record a, Record b)//比较a是否比b来得早
{
    if(a.in_hh != b.in_hh) return a.in_hh < b.in_hh;
    if(a.in_mm != b.in_mm) return a.in_mm < b.in_mm;
    return a.in_mm < b.in_mm;
}

bool MoreEqu(Record a, Record b)//比较a是否比b走得晚
{
    if(a.out_hh != b.out_hh) return a.out_hh > b.out_hh;
    if(a.out_mm != b.out_mm) return a.out_mm > b.out_mm;
    return a.out_mm > b.out_mm;
}

int main()
{
	int N = 0;
	Record sb = { 0 }, unlocked = { 0 }, locked = { 0 };
	unlocked.in_hh = 25;//设为无穷大
	scanf("%d", &N);
	for (int i = 0; i < N; i++)
	{
		scanf("%s %d:%d:%d %d:%d:%d",
                sb.ID, &sb.in_hh, &sb.in_mm, &sb.in_ss, &sb.out_hh, &sb.out_mm, &sb.out_ss);
        if(LessEqu(sb, unlocked)) unlocked = sb;//sb来得更早,说明是他开的门
        if(MoreEqu(sb, locked)) locked = sb;//sb走得更晚,说明是他关的门
	}
	printf("%s %s", unlocked.ID, locked.ID);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/85686404