hdu 1159 最长公共子序列

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32410    Accepted Submission(s): 14659


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
 
  
abcfbc abfcab programming contest abcd mnp
 

Sample Output
 
  
4 2 0
 

Source

Southeastern Europe 2003

#include <bits/stdc++.h>
using namespace std;
char s1[1001], s2[1001];
int dp[1001];
int main(){
    while(scanf("%s%s",s1,s2) !=EOF){
    	memset(dp,0,sizeof(dp));
    	int len1 = strlen(s1);
    	int len2 = strlen(s2);
        int old;
        int tmp ;
    	for(int i=0;i!=len1;++i){
    	old = 0;
    	for(int j=0;j!=len2;++j){
         tmp = dp[j];
         if(s1[i] == s2[j]) dp[j] = old+1;
         else  dp[j] = max(dp[j],dp[j-1]);
         old = tmp;
    	}	
    	}
    	printf("%d\n",dp[len2-1]);
    }
	return 0;
}


原创文章 54 获赞 168 访问量 63万+

猜你喜欢

转载自blog.csdn.net/bojie5744/article/details/51282099