A - Charm Bracelet POJ - 3624

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/liujie2232692543/article/details/90205507

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

我的代码:

#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <string.h>
//int dp[5005];	
int w[5005],d[5005];
int max(int a,int b)
{
	if(a > b)
		return a;
	else
		return b;
}

int main()
{
	int n,m;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		int dp[20000]={0};
		for(int i=0;i<n;i++)
		{
			scanf("%d %d",&w[i],&d[i]);
		}
	//	memset(dp,0,sizeof(dp));
		for(int i=0;i<n;i++)
		{
			for(int j=m;j>=w[i];j--)
			{
				dp[j] = max(dp[j],dp[j-w[i]] + d[i]);
			}
		}
		printf("%d\n",dp[m]);
	}
	return 0;
}

这是一个很裸的01背包。只有拿与不拿两种情况,找个最大的就可以了。

猜你喜欢

转载自blog.csdn.net/liujie2232692543/article/details/90205507
今日推荐