Charm Bracelet(poj 3464 0-1背包 动态规划)

Charm Bracelet

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 47080   Accepted: 20026

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

USACO 2007 December Silver

1.就算用了动态规划,还是超时。因为状态转化方程dp[][]大小要开到12880,像如下代码:

#include<iostream>
#include<cstdio> 
#include<cstring> 
#include<algorithm> 
using namespace std;
int dp[3600][13000];
int w[3600]; 
int money[3600];
int n,v;
int main()
{
	cin>>n>>v;
	for(int i=1;i<=n;i++)
	{
		scanf("%d%d",&w[i],&money[i]);
	}
	for(int j=1;j<=v;j++)
	{
		if(w[1]<=j)
		{
			dp[1][j]=money[j];
		}
		else
		{
			dp[1][j]=0;
		}
	}
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=v;j++)
		{
			if(j-w[i]>=0)
			  dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+money[i]);
			else
			  dp[i][j]=dp[i-1][j];
		}
	}
	  cout<<dp[n][v]<<endl;
	  return 0;  
	
}

2.因为它在更新的时候,只与上一行有关(如下面表格:详细背包讲解,见点击转到)可以考虑用滚动数组存储。因为是从左往右更新,用滚动数组的时候可以从右往左覆盖。

表格:

代码:

#include<iostream>
#include<cstdio> 
#include<cstring> 
#include<algorithm> 
using namespace std;
int w[3600];
int money[3600];
int dp[13000];
int n,v;
int main()
{
	cin>>n>>v;
	for(int i=0;i<n;i++)
	   scanf("%d%d",&w[i],&money[i]);
	memset(dp,0,sizeof(dp));
	for(int i=0;i<n;i++)
	{
		for(int j=v;j>=w[i];j--)
		  dp[j]=max(dp[j-w[i]]+money[i],dp[j]);
	}
	cout<<dp[v]<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SSYITwin/article/details/81604910