POJ 3624 Charm Bracelet(01背包模板题)

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 52318   Accepted: 21912

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N(1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

AC代码(模板题)

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int N = 13000;
int dp[N];
int s, n;//背包容积和物品数量

struct Thing
{
    int w;
    int v;
}list[3405];

void init()
{
    for (int i = 0; i <= s; i++)dp[i] = 0;
}

void package()
{
    for (int i = 0; i < n; i++)
    {
        for (int j = s; j >= list[i].w; j--)
        {
            dp[j] = max(dp[j], dp[j - list[i].w] + list[i].v);
        }
    }
}

int main()
{
    scanf("%d%d", &n, &s);
    for (int i = 0; i < n; i++)scanf("%d%d", &list[i].w, &list[i].v);
    init();
    package();
    printf("%d", dp[s]);
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/yun-an/p/11105955.html
今日推荐