POJ 3624 Charm Bracelet

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lizhaowei213/article/details/51114485
Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 31350   Accepted: 13943

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from theN (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factorDi (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more thanM (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers:Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source



简单O1背包水题,温习一下,瞬秒。

此题智能用一维DP数组,二维妥妥超内存。


一维AC


#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;

const int MAXN=3405;
const int MAXM=12885;
int dp[MAXM];
int weight[MAXN];
int value[MAXN];

int main()
{
        int n,m;
        while(scanf("%d%d",&n,&m)>0)
        {
                memset(dp,0,sizeof(dp));
                for(int i=1;i<=n;i++)
                        scanf("%d%d",&weight[i],&value[i]);
                for(int i=1;i<=n;i++)
                        for(int j=m;j>=weight[i];j--)
                                dp[j]=max(dp[j-weight[i]]+value[i],dp[j]);
                printf("%d\n",dp[m]);
        }
        return 0;
}

二维数组,方法正确,但此题会超内存


#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;

const int MAXN=3405;
const int MAXM=12885;
int dp[MAXN][MAXM];
int weight[MAXN];
int value[MAXN];

int main()
{
        int n,m;
        while(scanf("%d%d",&n,&m)>0)
        {
                memset(dp,0,sizeof(dp));
                for(int i=1;i<=n;i++)
                        scanf("%d%d",&weight[i],&value[i]);
                for(int i=1;i<=n;i++)
                        for(int j=1;j<=m;j++)
                        {
                                dp[i][j]=dp[i-1][j];
                                if(j>=weight[i])
                                        dp[i][j]=max(dp[i-1][j],dp[i-1][j-weight[i]]+value[i]);
                        }
                printf("%d\n",dp[n][m]);
        }
        return 0;
}


猜你喜欢

转载自blog.csdn.net/lizhaowei213/article/details/51114485
今日推荐