POJ-3624,Charm Bracelet(01背包)

Description:

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input:

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di 

Output: 

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints 

Sample Input: 

4 6

1 4

2 6

3 12

2 7 

Sample Output:

 23

程序代码: 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 100001
int dp[N],w[N],v[N];
int main()
{
	int n,m;
	scanf("%d %d",&n,&m);
	memset(dp,0,sizeof(dp));
	for(int i=0;i<n;i++)
		scanf("%d %d",&v[i],&w[i]);
	for(int i=0;i<n;i++)
	{
		for(int j=m;j>=v[i];j--)
		{
			dp[j]=max(dp[j],dp[j-v[i]]+w[i]);
		}
	}
	printf("%d\n",dp[m]);
	return 0;
}
扫描二维码关注公众号,回复: 9009476 查看本文章
发布了294 篇原创文章 · 获赞 304 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/weixin_43823808/article/details/104154932
今日推荐