【POJ3624】Charm Bracelet(01背包)

Description

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

注意要把数组开到题意指定大小,没看题目瞎做导致RE;

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"

using namespace std;

const int maxn = 12900;

int F[maxn][2];
int dp[maxn];

int max( int a,int b )
{
    return a>b? a:b;
}

int main()
{
    int n,m;
    memset(F,0,sizeof(F));
    while(~scanf("%d%d",&n,&m))
    {
        for( int i=1 ; i<=n ; i++ )
        {
            scanf("%d%d",&F[i][0],&F[i][1]);
        }
        memset(dp,0,sizeof(dp));
        for( int i=1 ; i<=n ; i++ )
           for( int j=m ; j>=F[i][0] ; j-- )
           {
            dp[j] = max( dp[j] , dp[j-F[i][0]]+F[i][1] );
           }
           printf("%d\n",dp[m]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/thesprit/article/details/50958801
今日推荐