POJ - Charm Bracelet(01背包)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lzyws739307453/article/details/86655000

题目链接:http://poj.org/problem?id=3624

Time Limit: 1000MS   Memory Limit: 65536K

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Problem solving report:

Description: 在已知手链的权重和美丽和魅力,求在权重限制的条件下,手链最大的魅力值。
Problem solving: 01背包。。。

#include <cstdio>
#include <cstring>
#include <iostream>
#define MAXN 12885
using namespace std;
int n, m, w[MAXN], v[MAXN], dp[MAXN];
int main()
{
    while (~scanf("%d%d", &n, &m))
    {
        memset(dp, 0, sizeof(dp));
        for (int i = 0; i < n; i++)
            scanf("%d%d", &w[i], &v[i]);
        for (int i = 0; i < n; i++)
            for (int j = m; j >= w[i]; j--)
                dp[j] = max(dp[j], dp[j - w[i]] + v[i]);
        printf("%d\n", dp[m]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lzyws739307453/article/details/86655000
今日推荐