Charm Bracelet POJ - 3624

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input
4 6
1 4
2 6
3 12
2 7
Sample Output
23
题意概括:有N个珠宝,每一都有其对应的魅力值Wi和重量Di,Bessie最多可拿重量为M的珠宝,问Bessie最多能有多少魅力值?


解题思路:简单的01背包模板题。


代码:

#include<stdio.h>
#include<string.h>
int c[4000],w[4000],f[300000];
int max(int a,int b)
{
	if(a<b)
		a=b;
	return a ;
}
int main()
{
	int i,j,n,v;
	
	while(scanf("%d%d",&n,&v)!=EOF)
	{
		memset(c,0,sizeof(c));
		memset(w,0,sizeof(w));
		memset(f,0,sizeof(f));
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&c[i],&w[i]);
		}
		for(i=0;i<n;i++)
		{
			for(j=v;j>=c[i];j--)
			{
				f[j]=max(f[j],f[j-c[i]]+w[i]);
			//	printf("%d ",f[j]);
			}
		//	printf("\n");
		}
		printf("%d\n",f[v]);	
	}
	return 0;	
} 


猜你喜欢

转载自blog.csdn.net/gakki_wpt/article/details/79235884
今日推荐