YTU 3142 动态规划进阶题目之Charm Bracelet

版权声明:转载请附上原文链接哟! https://blog.csdn.net/weixin_44170305/article/details/90056376

风华是一指流砂,苍老是一段年华。

题目描述

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

输入

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

输出

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

样例输入

copy

4 6
1 4
2 6
3 12
2 7

样例输出

23

提示

01背包问题,需要使用滚动数组进行优化,不然内存超限。

#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
int w[3500],d[3500],ml[13000];
int main()
{
    int he,m,n,i,j;
    scanf("%d",&n);
    scanf("%d",&m);
    for(i=0;i<n;i++)
    {
        scanf("%d",&w[i]);
        scanf("%d",&d[i]);
    }
    for(i=0;i<n;i++)
    {
        for(j=m;j>0;j--)
        {
            //if(w[i]<=j&&ml[j-w[i]]+d[i]>ml[j])
              //  ml[j]=ml[j-w[i]]+d[i];
              if(w[i]<=j)
                ml[j]=max(ml[j-w[i]]+d[i],ml[j]);
        }
    }
    he=0;
    for(i=0;i<=m;i++)
        he=max(he,ml[i]);
    cout<<he<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44170305/article/details/90056376