POJ 3579 Median 二分加判断

Median
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12453   Accepted: 4357

Description

Given N numbers, X1X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1X2, ... , XN, ( X≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

Source

 
二分答案+O(n)判断合法性
 
O(n^2)是明显不行的。二分枚举中位数,然后使用upper_bound / lower_bound 统计小于等于 arr[i]+mid 即 arr[j] - arr[i] <= mid 的个数 
 
#include<cstdio>
#include<algorithm>
using namespace std;
#define ll long long

const int maxn = 1e5+5;
int n;
ll m;
int arr[maxn];
bool valid(int mid){
    int cnt = 0;
    for(int i=0;i<n;i++){
        cnt += (upper_bound(arr+i,arr+n,arr[i]+mid)-1-(arr+i));
    }
    return cnt >= m;
}
int main(){
    while(scanf("%d",&n)!=EOF){
        for(int i=0;i<n;i++)
            scanf("%d",&arr[i]);
        sort(arr,arr+n);
        m = 1ll*n*(n-1)/2;
        if(m%2==0){
            m = m/2;
        }else m = m/2+1;
        int l = -1, r = arr[n-1]-arr[0];
        while(l <= r){
            int mid = (l+r)/2;
            if(valid(mid))
                r = mid-1;
            else
                l = mid+1;
        }
        printf("%d\n",l);
    }
    return 0;
}
View Code
扫描二维码关注公众号,回复: 6072418 查看本文章

猜你喜欢

转载自www.cnblogs.com/kongbb/p/10795899.html