POJ 3579 双重二分搜索:求列数X计算∣Xi – Xj∣组成新数列的中位数

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

题意:给定N个数,这些数字两两求差构成C(N,2)(即N*(N-1)/2)个数值,求这C(N,2)个数的中位数。

分析:算是第一次遇到这样二重二分的题目,首先O(n^2)的暴力不过,也不是数论,更不是DP,那就是朝二分上想,因为这道题目是让求任意两个数差所构成的中位数,因此可以想出|ai-aj|<mid的个数应大于C/2个(因为这是假设mid是我们所要求的最接近中位数的数,因此只能是大于,最后输出区间的左边界就好),为了方便起见,先将所有的ai从小到大排一下,然后得|aj-ai|<mid(j>i)的个数大于C/2==>aj<ai+mid的个数大于C/2;

PS一下:这里要会使用lower_bound函数

扫描二维码关注公众号,回复: 3925128 查看本文章
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
using namespace std;
typedef long long ll;
#define rep(i,l,r) for(int i=l;i<=r;i++)
const int N = 3e5 + 10;
const int MOD = 0x3f3f3f3f;
ll m;
int n;
int a[N];
bool solve(int x)
{
    ll tot=0;
    rep(i,0,n-1)
    tot+=n-(lower_bound(a,a+n,a[i]+x)-a);
    return tot>(m/2);
}
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    while(scanf("%d",&n)!=EOF){
        m=(n*(n-1))/2;
        rep(i,0,n-1)
        scanf("%d",&a[i]);
        sort(a,a+n);
        int L=0;int R=a[n-1]-a[0]+1;
        while(R-L>1){
            int mid=(L+R)/2;
            if(solve(mid))
                L=mid;
            else
                R=mid;
        }
        printf("%d\n",L);
    }
//    rep(i,0,4) scanf("%d",&a[i]);
//    printf("%d",lower_bound(a,a+3,11)-a);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/c___c18/article/details/83383989