POJ - 3579 Median (二分查找第k大的值)

                                                           Median

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!Description

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

本题采用二分方法

从0到最大差采用二分的方法寻找中位数

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[100010];
int n,k;


bool fun(int mid){
	int ans = 0;
	for(int i = 1;i<=n-1;i++){
//		for(int j = i+1;j <= n;j++){    //for循环超时。所以改用下边的方法
//			if(a[j]-a[i] <= mid) ans++;
//			else break;
//		}
		ans += upper_bound(a+i+1,a+n+1,mid+a[i])-(a+i+1);    //查找a[i+1]到a[n]大于等于mid+a[i]元素的个数。
	}
	if(ans < k) return true;  //如果小于k个,返回true
	else return false;
}

int main(){
	while(scanf("%d",&n)!=EOF){
		memset(a,0,sizeof(a));
		for(int i = 1;i <= n;i++){
			scanf("%d",&a[i]);
		}
		sort(a,a+n+1);
		k = n*(n-1)/2;
		if(k%2==0) k = k/2;  //偶数个差则除2
		else k = k/2+1;        //奇数个除2+1
		int l = 0,r = a[n]-a[1],mid;
		while(l<r){     //从0到最大差二分找中位数
			mid = (l+r)/2;
			if(fun(mid)){
				l = mid+1;    
			}else{
				r = mid;
			}
		}
		printf("%d\n",l);
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qlp_123/article/details/81408622