POJ 3579 Median 查找第k大的值

Given N numbers, X1X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i  j  N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1X2, ... , XN, ( X≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input
4
1 3 2 4
3
1 10 2
Sample Output
1
8

我们都知道 找中间这个数 那就用二分查找确定这个数关键是确定他是不是第k个

可以用for循环遍历跑

也可以直接用upper_bound 时间复杂度一样的

看代码吧

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
#define dbg(x) cout<<#x<<" = "<< (x)<< endl
const int MAX_N = 100005;
int arr[MAX_N];
int n,m;
int check(int d){
    int num = 0;
    for(int i=0;i<n;++i){
        num+=(upper_bound(arr+i,arr+n,arr[i]+d)-1-(arr+i));
    }
    if(num>=m) return 1;
    else return 0;
}
int main(){
    while(~scanf("%d",&n)){
        for(int i=0;i<n;++i)
            scanf("%d",&arr[i]);
        sort(arr,arr+n);
        int c = n*(n-1)/2;
        if(c%2==0){
            m=c/2;
        }
        else m = c/2+1;
        int l = 0,r = arr[n-1],now_right;
        while(l<=r){
            //dbg(l);
            //dbg(r);
            int mid = (l+r)>>1;
            if(check(mid))  {
                    //now_right = r;
                    r = mid-1;
             }
              else  l = mid+1;
        }
        printf("%d\n",max(l,r));
    }
   return 0;
}

猜你喜欢

转载自blog.csdn.net/heucodesong/article/details/80602476