POJ - 1163 :The Triangle

版权声明:本文为博主原创文章,未经博主允许不得转载。https://blog.csdn.net/uzzzhf https://blog.csdn.net/uzzzhf/article/details/89481512
7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30
//---------  方法一:递归程序(时间超限)  ---------------
#include <iostream>
#include <algorithm>
#define MAX 110

using namespace std;

int D[MAX][MAX];
int n;
int MaxSum(int i, int j)
{
    if(i == n)
        return D[i][j];
    int x = MaxSum(i+1,j);
    int y = MaxSum(i+1,j+1);
    return max(x,y) + D[i][j];
}
int main()
{
    int i,j;
    cin >> n;
    for(i=1;i<=n;i++)
        for(j=1;j<=i;j++)
            cin >> D[i][j]; //从D[1][1]开始
    cout << MaxSum(1,1) << endl;
}
//-----------  方法二:记忆递归型动归程序  ----------------
#include <iostream>
#include <cstdio>
#define MAX 110

using namespace std;

int D[MAX][MAX];
int maxSum[MAX][MAX];
int n;

int MaxSum(int i, int j)
{
    if(maxSum[i][j] != -1)
    {
        return maxSum[i][j];
    }

    else if(i == n)
    {
        maxSum[i][j] = D[i][j];
    }

    else
    {
        int x = MaxSum(i+1,j);
        int y = MaxSum(i+1,j+1);
        maxSum[i][j] = max(x,y) + D[i][j];
    }
    return maxSum[i][j];
}

int main()
{
    int i,j;
    cin >> n;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=i;j++)
        {
            cin >> D[i][j]; //从D[1][1]开始
            maxSum[i][j] = -1;
        }
    }
    cout << MaxSum(1,1) << endl;
    return 0;
}
//-----------  方法三:递归转成递推  -------------------

#include <iostream>
#include <cstdio>
#include <algorithm>
#define MAX 110

using namespace std;

int D[MAX][MAX];
int n;
int maxSum[MAX][MAX];
int main()
{
    int i,j;
    cin >> n;
    for(i=1;i<=n;i++)
        for(j=1;j<=i;j++)
            cin >> D[i][j]; //输入三角形

    for( int i = 1;i <= n; ++ i )
        maxSum[n][i] = D[n][i]; //最后一行值是固定的

    for( int i = n-1; i>= 1; --i ) //从下往上计算
        for( int j = 1; j <= i; ++j )
            maxSum[i][j] = max(maxSum[i+1][j],maxSum[i+1][j+1]) + D[i][j];

    cout << maxSum[1][1] << endl;
}
//-----------  方法四:递归转成递推同时空间优化  -------------------
#include <iostream>
#include <cstdio>
#include <algorithm>
#define MAX 110

using namespace std;

int D[MAX][MAX];
int n;
int main()
{
    int i,j;
    cin >> n;
    for(i=1;i<=n;i++)
        for(j=1;j<=i;j++)
            cin >> D[i][j]; //输入三角形

    for( int i = n-1; i>= 1; --i ) //从下往上计算
        for( int j = 1; j <= i; ++j )
            D[i][j] += max(D[i+1][j],D[i+1][j+1]);

    cout << D[1][1] << endl;
}

猜你喜欢

转载自blog.csdn.net/uzzzhf/article/details/89481512