POJ 1163 The Triangle(动态规划)

版权声明:本文为博主原创文章,欢迎转载。如有问题,欢迎指正。 https://blog.csdn.net/weixin_42172261/article/details/89634021

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int dp[105][105];
int n;
int main()
{
	scanf("%d", &n);
	for (int i=1; i<=n; i++)
		for (int j=1; j<=i; j++)
			scanf("%d", &dp[i][j]);
	for (int i=n-1; i>=1; i--)
		for (int j=1; j<=i; j++)
			dp[i][j]=max(dp[i+1][j], dp[i+1][j+1])+dp[i][j];
	printf("%d", dp[1][1]);
	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/weixin_42172261/article/details/89634021