POJ1163-The Triangle(数字三角形,经典DP)

版权声明:禁止盗用 https://blog.csdn.net/weixin_43411988/article/details/89221462

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output

Your program is to write to standard output. The highest sum is written as an integer.
Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30
Source

IOI 1994

题目大意

在上面的数字三角形中寻找一条从顶部到底边的路径,使得路径上所经过的数字之和最大。路径上的每一步都只能往左下或 右下走。只需要求出这个最大和即可,不必给出具体路径。 三角形的行数大于1小于等于100,数字为 0 - 99

题目链接
代码:

#include <iostream>
#include <algorithm>

using namespace std;

const int MAXN = 101;
int n;
int d[101][101];
int dp[101][101];
int main() {
	cin >> n;
	for (int i = 1; i <= n; i++)
		for (int j = 1; j <= i; j++)
			cin >> d[i][j];
	for (int i = 1; i <= n; i++)
		dp[n][i] = d[n][i];
	for (int i = n -1; i >= 1; i--) {
		for (int j = 1; j <= i; j++)
			dp[i][j] = max(dp[i+1][j],dp[i+1][j+1]) + d[i][j];
	}
	cout<<dp[1][1];
	return 0;
}

优化版代码

#include <iostream>
#include <algorithm>

using namespace std;

const int maxn = 101;
int n;
int d[maxn][maxn];
int* dp;
int main() {
	cin >> n;
	for (int i = 1; i <= n; i++)
		for (int j = 1; j <= i; j++)
			cin >> d[i][j];
	dp = d[n];
	for (int i = n - 1; i >= 1; i--)
		for (int j = 1; j <= i; j++)
			dp[j] = max(dp[j], dp[j + 1]) + d[i][j];
	cout << dp[1];
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43411988/article/details/89221462