POJ - 1163:The Triangle

POJ - 1163:The Triangle

来源:

标签:

参考资料:

相似题目:

题目

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

输出

Your program is to write to standard output. The highest sum is written as an integer.

输入样例

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

输出样例

30

解题思路

参考代码1

#include<stdio.h>
#include <algorithm> 
using namespace std;

const int maxn=100+10;
int arr[maxn][maxn],maxSum[maxn][maxn];
int n;

int getMaxSum(int x,int y)
{
    if(maxSum[x][y]!=-1)
        return maxSum[x][y];
    if(x==n)
        maxSum[x][y]=arr[x][y];
    else
    {
        int l=getMaxSum(x+1,y);
        int r=getMaxSum(x+1,y+1);
        maxSum[x][y]=max(l,r)+arr[x][y];
    }
    return maxSum[x][y];
}

int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=i;j++)
        {
            scanf("%d",&arr[i][j]);
            maxSum[i][j]=-1;
        }

    }
    printf("%d\n",getMaxSum(1,1));
}

参考代码2

#include<stdio.h>
#include <algorithm> 
using namespace std;

const int maxn=100+10;
int arr[maxn][maxn],maxSum[maxn][maxn];
int n;

int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        for(int j=1;j<=i;j++)
            scanf("%d",&arr[i][j]);

    for(int i=n;i>=1;i--)
    {
        for(int j=1;j<=i;j++)
        {
            if(i==n)
                maxSum[i][j]=arr[i][j];
            else
                maxSum[i][j]=max(maxSum[i+1][j],maxSum[i+1][j+1])+arr[i][j];
        }
    }
    printf("%d\n",maxSum[1][1]);
}

参考代码3

#include<stdio.h>
#include <algorithm> 
using namespace std;

const int maxn=100+10;
int arr[maxn][maxn];
int n;

int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        for(int j=1;j<=i;j++)
            scanf("%d",&arr[i][j]);

    int *p=arr[n];

    for(int i=n-1;i>=1;i--)
        for(int j=1;j<=i;j++)
            p[j]=max(p[j],p[j+1])+arr[i][j];

    printf("%d\n",p[1]);
}

猜你喜欢

转载自blog.csdn.net/wingrez/article/details/80463313