poj 1163 The Triangle(dp)

题目链接:http://poj.org/problem?id=1163

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

类似于杨辉三角问题。这个题是从顶端开始,只能向左下或右下前进。问最大值是多少.

#pragma GCC optimize(2)
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
const int maxn = 500;
const int inf = 0x3f3f3f3f;
typedef long long ll;
int dp[maxn][maxn];
int mp[maxn][maxn];
int main()
{
	//freopen("C://input.txt", "r", stdin);
	int n;
	scanf("%d", &n);
	for (int i = 1; i <= n; i++)
	{
		for (int j = 1; j <= i; j++)
		{
			scanf("%d", &mp[i][j]);
		}
	}
	dp[1][1] = mp[1][1];
	for (int i = 2; i <= n; i++)
	{
		for (int j = 1; j <= i; j++)
		{
			dp[i][j] = max(dp[i - 1][j - 1] + mp[i][j], dp[i - 1][j] + mp[i][j]);
		}
	}
	int ma = -inf;
	for (int i = 1; i <= n; i++)
	{
		ma = max(ma, dp[n][i]);
	}
	printf("%d\n", ma);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Evildoer_llc/article/details/82976320