poj-3624

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 44234   Accepted: 18997

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

/*有n个物品,分别有不同的重量wi和价值di,Bessie只能
带走重量不超过M的物品,要是总价值最大,并输出总价值f(m)。*/
#include<stdio.h>
#include<string.h>
static const int MAXN = 3450;
static const int MAXM = 12890;
int f[MAXM];
int w[MAXN], d[MAXN];
int main()
{
  int n,m;///n为件数,m为重量
  scanf("%d%d",&n,&m);
  for(int i=1;i<=n;i++)
  {
   scanf("%d%d",&w[i],&d[i]);///w[i]为重量,d[i]为价值
  }
  memset(f,0,sizeof(f));///初始化
  for(int i=1;i<=n;i++)
  {
    for(int j=m;j>=w[i];j--)
    {
      if(f[j]<f[j-w[i]]+d[i])///背包公式
      {
        f[j]=f[j-w[i]]+d[i];
      }
    }
  }
  printf("%d\n",f[m]);
  return 0;
}

猜你喜欢

转载自blog.csdn.net/fenger_c/article/details/79760450