poj3624

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

USACO 2007 December Silver
01背包问题,需要使用滚动数组,不然会超内存
Memory Limit Exceeded
#include<cstdio>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<vector>
#include<string>
#include<map>
#include<cstring>
#define DEBUG(x) cout << #x << " = " << x << endl
using namespace std;
const int MAXN=3500;
const int MAXM=13000;
int dp[MAXN][MAXM];///前i件物品不超过体积j的最大价值
int N,M;
int W[MAXN];
int D[MAXN];
int main()
{
//    freopen("in.txt","r",stdin);
    scanf("%d %d",&N,&M);
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=N;i++){
        scanf("%d %d",&W[i],&D[i]);
    }
    for(int i=1;i<=M;i++){
        if(W[1]<=i)
            dp[1][i]=D[1];
    }
    for(int i=1;i<=N;i++){
        for(int j=1;j<=M;j++){
            dp[i][j]=dp[i-1][j];
            if(j-W[i]>=0)dp[i][j]=max(dp[i][j],dp[i-1][j-W[i]]+D[i]);
        }
    }
    printf("%d\n",dp[N][M]);
    return 0;
}
View Code

AC

#include<cstdio>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<vector>
#include<string>
#include<map>
#include<cstring>
#define DEBUG(x) cout << #x << " = " << x << endl
using namespace std;
const int MAXN=3500;
const int MAXM=13000;
int dp[MAXM];///前i件物品不超过体积j的最大价值
int N,M;
int W[MAXN];
int D[MAXN];
int main()
{
//    freopen("in.txt","r",stdin);
    scanf("%d %d",&N,&M);
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=N;i++){
        scanf("%d %d",&W[i],&D[i]);
    }
    for(int i=1;i<=M;i++){
        if(W[1]<=i)
            dp[i]=D[1];
    }
    for(int i=2;i<=N;i++){
        for(int j=M;j>=1;j--){
            if(j-W[i]>=0)dp[j]=max(dp[j],dp[j-W[i]]+D[i]);
        }
    }
    printf("%d\n",dp[M]);
    return 0;
}
View Code
 

猜你喜欢

转载自www.cnblogs.com/MalcolmMeng/p/9165546.html
今日推荐