POJ-3264 (Balanced Lineup)

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2.. NQ+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

询问a~b的极差

用两个query分别求最大值和最小值,然后相减即可

#include<cstdio>
#include<algorithm>
#define maxn 100007
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
int mini[maxn<<2],maxi[maxn<<2];
int a[maxn],n;

void pushup(int rt)
{
   mini[rt]=min(mini[rt<<1],mini[rt<<1|1]);
   maxi[rt]=max(maxi[rt<<1],maxi[rt<<1|1]);
}

void build(int l,int r,int rt) {
    if (l == r) {
        mini[rt]=maxi[rt]=a[l];
        return ;
    }
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
    pushup(rt);
}

int query(int L,int R,int l,int r,int rt) {
    if (L <= l && r <= R) {
        return maxi[rt];
    }
    int m = (l + r) >> 1;
    int ret = 0;
    if (L <= m) ret =query(L , R , lson);
    if (R > m) ret =max(ret,query(L , R , rson));
    return ret;
}

int query2(int L,int R,int l,int r,int rt) {
    if (L <= l && r <= R) {
        return mini[rt];
    }
    int m = (l + r) >> 1;
    int ret = 9999999;///注意这里求最小值,ret要重置为极大值
    if (L <= m) ret =query2(L , R , lson);
    if (R > m) ret =min(ret,query2(L , R , rson));
    return ret;
}

int main()
{
    int n,q,x,y;
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
    build(1,n,1);
    for(int i=0;i<q;i++)
    {
        scanf("%d%d",&x,&y);
        printf("%d\n",query(x,y,1,n,1)-query2(x,y,1,n,1));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41183791/article/details/81287918