HDU-1087 Super Jumping! Jumping! Jumping! (线性DP)

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the maximum according to rules, and one line one case.
 

Sample Input
 
   
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
 
   
4 10 3
 

题意:按从左到右的顺序选取一个严格递增的子序列,使这个子序列和最大。

思路:定义dp[i]为以第i个人结尾的最优解,假设已知前i-1个最优解,那么dp[i]的解:遍历前i-1个,在a[i]>a[j]的基础上,求出dp[j]+a[i]的最大值即为dp[i]的最优解。状态转移过程与LIS非常相似。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define ll long long
using namespace std;
ll n,a[1010],dp[1010];
int main()
{
    while(~scanf("%lld",&n))
    {
        if(n==0)break;
        for(ll i=1;i<=n;i++)scanf("%lld",&a[i]);
        for(ll i=1;i<=n;i++)dp[i]=a[i];
        ll mmax=dp[1];
        for(ll i=2;i<=n;i++)
        {
            for(ll j=1;j<i;j++)
            {
                if(dp[j]<dp[i])
                {
                    dp[i]=max(dp[i],dp[j]+a[i]);
                }
            }
            mmax=max(dp[i],mmax);
        }
        printf("%lld\n",mmax);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/s540239976/article/details/80052282
今日推荐