HDU - 2795 Billboard(线段树)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chenshibo17/article/details/86566460

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information. 

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard. 

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi. 

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one. 

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university). 

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases). 

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements. 

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

Sample Input

3 5 5
2
4
3
3
3

Sample Output

1
2
1
3
-1

           明显的需要区间最大值~用线段树就好了。。主义的一个点就是n可能是1e9的范围,在这种情况下,我们设置n=num就好了,因为每块最多占用一行。

#include<bits/stdc++.h>
using namespace std;
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
const int maxn = 2e5 + 10;
int sum[maxn << 2];
int n, m, num;
void pushup(int l,int r,int rt) {
	sum[rt] = max(sum[rt << 1], sum[rt << 1 | 1]);
}
void build(int l, int r, int rt) {
	if (l == r) {
		sum[rt] = m;
		return;
	}
	int mid = (l + r) >> 1;
	build(lson); build(rson);
	pushup(l,r,rt);
}
void query(int need,int l, int r, int rt,int &pos) {
	if (l == r) {
		pos = l;sum[rt] -= need;
		return;
	}
	int mid = (l + r) >> 1;
	if (sum[rt << 1] >= need) query(need, lson, pos);
	else if (sum[rt << 1 | 1] >= need) query(need, rson, pos);
	pushup(l, r, rt);
}
int main() {
	while (~scanf("%d%d%d", &n, &m, &num)) {
		if (n > num)n = num;
		build(1, n, 1);
		while (num--) {
			int t, pos = -1;
			scanf("%d", &t);
			if (sum[1] < t)
				cout << -1 << endl;
			else{
				query(t, 1, n, 1, pos);
				cout << pos << endl;
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/chenshibo17/article/details/86566460
今日推荐