Billboard HDU - 2795

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_40758751/article/details/82380221

Billboard

HDU - 2795

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

Sample Input

3 5 5
2
4
3
3
3

Sample Output

1
2
1
3
-1

AC代码

//#include<bits/stdc++.h>
#define _CRT_SBCURE_NO_DEPRECATE
#include <set>
#include <map>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
//#define UP(i,x,y) for(int i=x;i<=y;i++)
//#define DOWN(i,x,y) for(int i=x;i>=y;i--)
//#define sd(x,y,z) scanf("%d%d%d", &x, &y, &z)
//#define sd(x,y) scanf("%d%d", &x, &y)
#define sd(x) scanf("%d", &x)
//#define mp make_pair
#define pb push_back
using namespace std;
typedef long long ll;
#define MOD 1000000007
const int maxn = 201000;
const int INF = 0x3f3f3f3f;
const ll LINF = 0x3f3f3f3f3f3f3f3f;

int n, m, t, _n;
int dat[maxn<<2];
void init(int _n)
{
	n = 1;
	while(n<_n) n<<=1;
	for(int i = 0; i < 2*n-1; i++)
		dat[i] = m;
	for(int i = 2*n-2; i >= _n+n-1; i--)
		dat[i] = 0;
}
void add(int k, int v)
{
	k+=n-1;
	dat[k] -= v;
	while(k)
	{
		k = (k-1)/2;
		dat[k] = max(dat[k*2+1],dat[k*2+2]);
	}
}
int query(int k, int v, int l, int r)
{
	if(r-l==1)
	{
		if(dat[k] >= v)
			return k - n + 1;
		else
			return -1;
	}
	else
	{
		if(dat[k*2+1] >= v)
		{
			return query(k*2+1, v, l, (l+r)/2);
		}
		else
		{
			return query(k*2+2, v, (l+r)/2, r);
		}
	}
}
int main()
{
	//freopen("in.txt", "r", stdin);
	while(~scanf("%d%d%d", &_n, &m, &t))
	{
		_n = min(_n, 200000);
		init(_n);
		int ta;
		while(t--)
		{
			scanf("%d", &ta);
			int ans = query(0, ta, 0, n);
 			if(ans != -1)
			{
				add(ans, ta);
				printf("%d\n", ans+1);
			}
			else printf("-1\n");
		}
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40758751/article/details/82380221