HDU2795-Billboard

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.
Sample Input
3 5 5
2
4
3
3
3
Sample Output
1
2
1
3
-1

分析:

题意:
第一行给出三个数(h,w,n),分别表示公告板的高度、宽度以及张贴的公告数,然后是n行,每一行一个整数,表示公告的宽度,默认公告的高度为1,要求贴的公告从最底部开始贴,而且尽量往左贴!

用线段树解决,数组tree[]表示从i~j行这个区间内所有行所剩的宽度的最大值。

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#define N 200005

using namespace std;

int tree[N<<2];
int h,w,n;

void build(int l,int r,int i)
{
	tree[i]=w;
	if(l==r)
		return;
	int mid=(l+r)>>1;
	build(l,mid,i<<1);
	build(mid+1,r,i<<1|1);
}

int query(int l,int r,int i,int width)
{
	if(tree[i]<width)
		return -1;
	if(l==r)
		return l;
	int mid=(l+r)>>1;
	if(tree[i<<1]>=width)
		return query(l,mid,i<<1,width);
	if(tree[i<<1|1]>=width)
		return query(mid+1,r,i<<1|1,width);
}

void updata(int l,int r,int i,int t,int width)
{
	if(l==r)
	{
		tree[i]-=width;
		return;
	}
	int mid=(l+r)>>1;
	if(t<=mid)
		updata(l,mid,i<<1,t,width);
	else
		updata(mid+1,r,i<<1|1,t,width);
	tree[i]=max(tree[i<<1],tree[i<<1|1]);
}

int main()
{
	int m,width;
	while((cin>>h>>w>>n)&&h&&w&&n)
	{
		h=min(h,n);
		build(1,h,1);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&width);
			if(width>w)
				printf("-1\n");
			else
			{
				printf("%d\n",m=query(1,h,1,width));
				if(m>0)
					updata(1,h,1,m,width);
			}
		}
	}
	return 0;
}
发布了46 篇原创文章 · 获赞 16 · 访问量 418

猜你喜欢

转载自blog.csdn.net/weixin_43357583/article/details/104945675