HDU - 2795 - Billboard(线段树 & 思维)

HDU - 2795 - Billboard

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.
Sample Input
3 5 5
2
4
3
3
3
Sample Output
1
2
1
3
-1
题目链接

题目大意是给你一个墙h * w,然后往上贴公告,每个公告宽度告诉你,然后高度是1。问能不能贴上,贴上的话问在第几行,不能输出-1。并且还要尽量往上贴,往左。
这个题目,我看了一个题解,很赞,思想是看一下到底多少行,然后按行数建树。当然不用申请1e9的数组,,因为一共就n次个海报,然后记录每一行的宽度,询问的时候顺便减掉一部分长度。每个节点都代表了一行,记录宽度最长的,在比较的时候,先看一下左边是不是比海报宽,如果是的话就找左边的节点,也就是前几行。
题解链接

AC代码:

#include <cstdio>
#include <iostream>
#define lson l, m, cur << 1
#define rson m + 1, r, cur << 1 | 1
using namespace std;
const int maxn = 2e5 + 5;
int p[maxn << 2], h, w, n;

void pushup(int cur)
{
    p[cur] = max(p[cur << 1], p[cur << 1 | 1]);
}

void build(int l, int r, int cur)
{
    p[cur] = w;
    if(l == r)  return ;
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
}

int query(int val, int l, int r, int cur)
{
    if(l == r)
    {
        p[cur] -= val;
        return l;
    }
    int m = (l + r) >> 1, ans;
    if(p[cur << 1] >= val)  ans = query(val, lson);
    else    ans = query(val, rson);
    pushup(cur);
    return ans;
}

int main()
{
    while(~scanf("%d%d%d", &h, &w, &n))
    {
        if(h > n)   h = n;
        build(1, h, 1);
        while(n--)
        {
            int x;
            scanf("%d", &x);
            if(p[1] < x)    printf("-1\n");
            else    printf("%d\n", query(x, 1, h, 1));
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40788897/article/details/81606006
今日推荐