线段树Billboard HDU - 2795

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/zhangxiaoduoduo/article/details/82841470

                                                  Billboard         HDU - 2795 

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information. 

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard. 

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi. 

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one. 

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university). 

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases). 

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements. 

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

Sample Input

3 5 5
2
4
3
3
3

Sample Output

1
2
1
3
-1

题意:一个h*w的公告牌,要在其上贴公告。

输入的是1*wi的w值,这些是公告的尺寸

接下来要满足的条件有:1、尽量往上,同一高度尽量靠左。2、求第n个广告所在的行数。3、没有合适的位置贴了则输出-1。

思路:线段树,每个位置上存储的是:eg:tree[2].l = 1,tree[2].r=5,tree[2].maxx代表从第一行到第五行,能存放的最大的广告的长度。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 200010
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 1000000007
#define P pair<int,int>
#define MID(l,r) (l+(r-l)/2)
#define lson(o) (o<<1) //o*2
#define rson(o) (o<<1|1) //o*2+1
using namespace std;

int h,w,n;
struct node
{
    int l,r,maxx;
}tree[maxn*4];
void build(int o,int l,int r)
{
    tree[o].l = l;
    tree[o].r = r;
    if(l==r){
        tree[o].maxx = w;
        return ;
    }
    int m = MID(l,r);
    int lc = lson(o),rc = rson(o);
    build(lc,l,m);
    build(rc,m+1,r);
    tree[o].maxx = max(tree[lc].maxx , tree[rc].maxx);
}
int x;
int query(int o)
{
    if(tree[o].l == tree[o].r){
        return tree[o].l;
    }
    int m =MID(tree[o].l,tree[o].r);
    int lc = lson(o),rc = rson(o);
    if(tree[lc].maxx >= x) query(lc);
    else return query(rc);
}
//单点更新
int p,v;
void update(int o)
{
    if(tree[o].l == tree[o].r){
        tree[o].maxx += v;
        return ;
    }
    int m = MID(tree[o].l,tree[o].r);
    int lc = lson(o),rc = rson(o);
    if(p<=m) update(lc);
    else update(rc);
    tree[o].maxx = max(tree[lc].maxx,tree[rc].maxx);
}
int main()
{
    while(scanf("%d %d %d",&h,&w,&n)!=EOF){
        h = min(h,n);
        build(1,1,h);
        while(n--){
            scanf("%d",&x);
            if(x>tree[1].maxx){
                printf("-1\n");
                continue;
            }
            else{
                int ans = query(1);
                printf("%d\n",ans);
                p = ans;
                v = -x;
                update(1);
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zhangxiaoduoduo/article/details/82841470
今日推荐