包装的线段树--HDU 2795 Billboard

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37891604/article/details/82142028

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

Sample Input

3 5 5 2 4 3 3 3

Sample Output

1 2 1 3 -1

Author

hhanger@zju

题目大意:一个h*w的公告牌,要在其上贴公告。

输入的是1*wiw值,这些是公告的尺寸

接下来要满足的条件有:1、尽量往上,同一高度尽量靠左。2、求每个广告所在的行数。没有合适的位置贴了则输出-1叶子节点只有min(n, h)个,n个广告,每个广告一行才n行,h再大往后也用不到了,不要被10^9吓到;然后把每行的空间存进树,每贴一条广告就删除相应的空间。此题对高度h建立线段树,每个节点储存的是这一行最大的空位。

#include <iostream>
#include <cstdio>
#include <cstring>
 
using namespace std;
 
struct node
{
    int l,r;
    int Max;//这段区间内有最多空位的那一行的空位长度
} s[200000*4];
 
void InitTree(int l,int r,int k,int w)
{
    s[k].l=l;
    s[k].r=r;
    s[k].Max=w;
    if (l==r)
        return ;
    int mid=(l+r)/2;
    InitTree(l,mid,2*k,w);
    InitTree(mid+1,r,2*k+1,w);
}
 
void UpdataTree(int ww,int k)
{
    if (s[k].l==s[k].r)
    {
        printf ("%d\n",s[k].l);
        s[k].Max-=ww;
        return ;
    }
    if (ww<=s[k*2].Max)
        UpdataTree(ww,k*2);
    else
        UpdataTree(ww,k*2+1);
    s[k].Max=s[k*2].Max>s[k*2+1].Max?s[k*2].Max:s[k*2+1].Max;
}
 
int main()
{
    int h,w,n;
    int ww;
    while (~scanf("%d%d%d",&h,&w,&n))
    {
        if (h>n)//h<=n,大了就没有意义了
            h=n;
        InitTree(1,h,1,w);
        for (int i=1; i<=n; i++)
        {
            scanf("%d",&ww);
            if (s[1].Max>=ww)
                UpdataTree(ww,1);
            else
                printf ("-1\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37891604/article/details/82142028
今日推荐