hdu2795(Billboard)

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information. 

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard. 

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi. 

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one. 

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university). 

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases). 

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements. 

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

Sample Input

3 5 5
2
4
3
3
3

Sample Output

1
2
1
3
-1

计算最多可以放广告牌的数量,优先向上向左放置.

维护区间最大值,并优先修改左子树

sum[1]为根结点,代表整个树最大的空位,如果广告牌比它大,呢么就输出-1.

AC:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#define maxi 200001
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
using namespace std;
int sum[maxi<<2],a[maxi];

void pushup(int rt) {
    sum[rt] = max(sum[rt<<1],sum[rt<<1|1]);
}

void build(int l,int r,int rt,int w ) {
    if (l == r) {
        sum[rt]=w;
        return ;
    }
    int m = (l + r) >> 1;
    build(lson,w);
    build(rson,w);
    pushup(rt);
}

int query(int mx,int l,int r,int rt)
{
    if(l==r)//找到
    {
        sum[rt]-=mx;
        return l;
    }
    int m=(l+r)>>1,ret;
    if(sum[rt<<1]>=mx) ret=query(mx,lson);//优先向左查找
    else ret=query(mx,rson);
    pushup(rt);             //更新加点
    return ret;
}

int main()
{
    int w,h,n,m,d;
    while(scanf("%d%d%d",&h,&w,&n)!=EOF)
    {
        if(n<h) h=n;
        build(1,h,1,w);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&m);
            if(sum[1]<m)//如果和最大的和小于m,则输出-1
                printf("-1\n");
            else printf("%d\n",query(m,1,h,1));
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41183791/article/details/81323932