HUD3555Bombs数位DP模板

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point. 
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them? 

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description. 

The input terminates by end of file marker. 

Output

For each test case, output an integer indicating the final points of the power.

Sample Input

3
1
50
500

Sample Output

0
1
15
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define ll long long
using namespace std;
ll dp[100][10];
int bit[105];
int t;
ll dfs(int pos,int sta,int limit)
{
    if(pos==-1)
        return sta==2;
        if(!limit&&dp[pos][sta]!=-1)
            return dp[pos][sta];
        int up=limit?bit[pos]:9;
        int nsta;
        ll ans=0;
        for(int i=0;i<=up;i++)
        {
            nsta=sta;
            if(sta==2)
                nsta=2;
            else  if(sta==1&&i==9)
                nsta=2;
            else if(sta==0&&i==4)
                nsta=1;
                else if(sta==1&&i!=4)
                    nsta=0;
                    ans+=dfs(pos-1,nsta,limit&&i==up);

        }
        if(!limit)
        dp[pos][sta]=ans;
        return ans;

}
ll solve(ll x)
{int pos=0;
    while(x)
{
    bit[pos++]=x%10;
    x/=10;
}
       return dfs(pos-1,0,1);
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {ll n;
    memset(dp,-1,sizeof(dp));
        scanf("%lld",&n);
        printf("%lld\n",solve(n));

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/89194690