【PAT 】PAT Advance 1002 A+B for Polynomials 多项式相加

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ … N​K​​ a​N​K​​​​
where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

题目大意

将两个多项式相加,输出不为0的项数, 以及各项的幂和底数。

代码

//
//  main.c
//  PAT1002
//
//  Created by 许少钧 on 2019/4/6.
//  Copyright © 2019年 许少钧. All rights reserved.
//
#define err 1e-7
#include <math.h>
#include <stdio.h>
int main() {
    double a[1001] = {0.0};
    int k;
    double tempA;
    int tempN;
    int count = 0, max = 0;
    
    // 读入第一个多项式并存储
    scanf("%d", &k);
    for(int i = 0; i < k; i++){
        scanf("%d %lf", &tempN, &tempA);
        if(i == 0)max = tempN;
        a[tempN] = tempA;
    }
    count = k;
    
    // 读入第二个多项式的同时直接计算
    scanf("%d", &k);
    for(int i = 0; i < k; i++){
        scanf("%d %lf", &tempN, &tempA);
        // 原来没有这一项,增加后就会多一项
        if(fabs(a[tempN]) < err){
            count++;
            if(tempN > max) max = tempN;
        }
        a[tempN] += tempA;
        
        // 计算结果趋近于0,减少一项
        if(fabs(a[tempN]) < err){
            count--;
        }
    }
    
    printf("%d", count);
    
    // 输出N和an
    for(int i = max; i >= 0; i--){
        if(fabs(a[i]) > err){
            printf(" %d %.1f", i, a[i]);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a617976080/article/details/89053218
今日推荐